Records For Living Community

Share Information about HealthFrame and taking control of your own healthcare
Welcome to Records For Living Community Sign in | Join | Help
in Search


Last post 12-06-2006, 10:30 AM by Records For Living Support. 12 replies.
Sort Posts: Previous Next
  •  12-02-2006, 10:25 PM 543



    Just installed Ver 2.1.3
    Updated/Installed fine but ABOUT still shows Ver 2.1.2

    Pleas update

  •  12-03-2006, 9:01 AM 544 in reply to 543

    Re: About

    Attachment: about213.GIF

    Good morning, Brian!

    I tried reproducing the problem you reported, but I couldn't.  When I see the About box it shows me version 2.1.3 (please see image below).

    Please do me a favor and go to your Help / Check Online for Software Updates.  What do you see?

    Thanks and Happy Holidays!

    Support Team

    Records For Living

  •  12-03-2006, 9:23 AM 545 in reply to 544

    Re: About

    Your Version

    You appear to be running HealthFrame version 2.1.2.

    A minor update is available

    This minor update is completely free to customers with a HealthFrame 2.x license.

    • HealthFrame 2.1.3
      This release fixes a bug with spaces at the end of a person-name; adds new OpenHealth services; clarfies startup screen in HealthFrame Viewer; provides better error messages with remote OpenHealth services; improved suggestions; disable 'install for this user only' from installer; automatic check for updates; and several other minor fixes.

    It says I have 2.1.2 but I can see the new OHR plugin ( re: clinical trials)

    I will do a complete uninstall/reinstall and see what happens



    Just did the above and all is well Ver 2.1.3 showing
  •  12-03-2006, 10:10 AM 546 in reply to 545

    Re: About

    The fact that you see the new 'Find Clinical Trials' plug-in does suggest that you have installed HealthFrame 2.1.3 (which obviously contradicts the version# you see).

    Are you installing in the standard (default) disk location (c:\Program Files)?

    As you suggested, taking the process in peices maybe the best way to proceed.
    • First download the 2.1.3 update.
    • Look at it (right click and say 'properties') - and verify that you have the right digitial signature, and that the version of the installer says '2.1.3'.
    • Un-install whatever version of HealthFrame you have
    • Verify that the c:\Program Files\Records For Living, Inc folder - and its contents - are gone (or at least that he program file is gone; of course this assumes you've installed to the default location).
    • Then run the new - 2.1.3 - installer.
    • When you have finsihed installing - the 'ReadMe' file that comes up ALSO displays the version of the software you've just installed.
    • Also from the 'Start/Program Files/Records For Living/' menu the 'Installation Notes' file also shows the version. Similarly for the Help file.
    • Then run HealthFrame, and check its version#.

    I realize that's a lot of steps. You can skip whichever ones you want. But if you are trying to decompose the installation process, and see where things break down - these are the key points to look at to identify where the installation process is failing.

                             Support Team.

  •  12-03-2006, 10:11 PM 547 in reply to 546

    Re: About

    Hello Team

    I uninstalled HealthFrame completely and removed the directory (c:\Program Files\Records For Living),
    then re-installed 2.1.3.

    ABOUT is now showing correctly.


  •  12-04-2006, 6:43 PM 548 in reply to 547

    Re: About

    Do you happen to recall what files you found left in:

       c:\Program Files\Records For Living\HealthFrame v2\

    after having un-installed?

    It should have been deleted by the uninstaller (except in some rare cases where logfiles might still be there).

    If we have some (rare) bug with our un-installer, we'd like to know so that we can begin tracking that down.

    Of course - we are glad you have no successfully installed HealthFrame 2.1.3 ;-)


                               Support Team.


  •  12-04-2006, 8:02 PM 549 in reply to 548

    Re: About

    Sorry no idea, except to say that the folder/subfolders were still there.
    Do not know if they contained files or not


  •  12-05-2006, 9:11 PM 550 in reply to 549

    Re: About

    Hello Team

    Just installed ver 2.1.4

    ABOUT still shows 2.1.3

    Control Panel >Add/Remove Programs>Healthframe (Uninstalled)

    The Entire Records for the Living > Healframe >Folders>Sub Folders and files are STILL THERE.

    Will now Delete Entire Folder (Records for the Living) and do the update.

    Updated to Ver 2.1.4 OK

    For your information

    Brian Phelan

  •  12-06-2006, 7:29 AM 551 in reply to 550

    Re: About

    Well, it's helpfull that your installation problem is repeatable, but unfortunately we've been unable to reproduce it here.

    Running the 2.1.4 installer should automatically un-install the 2.1.3 code first. That part appears to be working.

    Your trouble appears to be that running the installation (whether from the 2.1.4 installer or directly from the Add/Remove Programs control panel) - 'appears' to run to completion, but in fact - is not truely deleting files.

    That suggests that something in your registry is corrupted.

    Perhaps we could schedule a time when someone from our support team could look at the registry on your computer? Perhaps even run the installation manually - from the command line - so that we can get a debugging log?

    If you are willing to try this, please send email with possible times when we could connect to your computer (you will need about 30 minutes and a high speed internet connection). Send email to

              Support Team.

  •  12-06-2006, 8:02 AM 552 in reply to 551

    Re: About


    Thanks for the offer, but as I am running a small network behind a firewall etc, I will have to decline your offer.

    I have also uninstalled (using XPLite) some windows components and do not wish to reinstall them

    It is really no problem as HealthFrame runs really well for me.


    Brian Phelan
  •  12-06-2006, 8:27 AM 553 in reply to 552

    Re: About

    Understood. Maybe this will work.

    Please download:

    (thats the same version you currently have installed - but can be run directly with msiexec).

    • copy that file to some directory on your computer (e.g. c:\temp)
    • run a comamnd shell (Start/Run cmd.exe)
    • msiexec /x Install_HealthFrame_FamilyEdition_Release_2.1.4.msi /lv myHFLog.log
    Running that msiexec will do the SAME THING as uninstalling from the Add/ Remove control panel, excpet that by running it from a command line, you can specify the logging option (/lv).

    Please verify that the files were NOT properly uninstalled (left in your c:\program files\records for living directory).

    And then please send me the logfile.

    (then you can re-install HealthFrame - either by double clicking this MSI, or using your original installer.

    This logfile will give me some ideas as to WHY your uninstall is not proceeding properly.

              Support Team.

  •  12-06-2006, 10:11 AM 554 in reply to 553

    Re: About

    Just completed action outlined above.
    See copy of myhflog.log below.


    === Verbose logging started: 07/12/2006  00:43:57  Build type: SHIP UNICODE 3.01.4000.2435  Calling process: C:\WINDOWS\system32\msiexec.exe ===
    MSI (c) (28:4C) [00:43:57:203]: Resetting cached policy values
    MSI (c) (28:4C) [00:43:57:203]: Machine policy value 'Debug' is 0
    MSI (c) (28:4C) [00:43:57:203]: ******* RunEngine:
               ******* Product: install_healthframe_FamilyEdition_Release_2.1.4.msi
               ******* Action:
               ******* CommandLine: **********
    MSI (c) (28:4C) [00:43:57:203]: Client-side and UI is none or basic: Running entire install on the server.
    MSI (c) (28:4C) [00:43:57:203]: Grabbed execution mutex.
    MSI (c) (28:4C) [00:43:57:218]: Cloaking enabled.
    MSI (c) (28:4C) [00:43:57:218]: Attempting to enable all disabled priveleges before calling Install on Server
    MSI (c) (28:4C) [00:43:57:218]: Incrementing counter to disable shutdown. Counter after increment: 0
    MSI (s) (DC:B4) [00:43:57:234]: Grabbed execution mutex.
    MSI (s) (DC:C8) [00:43:57:234]: Resetting cached policy values
    MSI (s) (DC:C8) [00:43:57:234]: Machine policy value 'Debug' is 0
    MSI (s) (DC:C8) [00:43:57:234]: ******* RunEngine:
               ******* Product: E:\Temp\install_healthframe_FamilyEdition_Release_2.1.4.msi
               ******* Action:
               ******* CommandLine: **********
    MSI (s) (DC:C8) [00:43:57:234]: Machine policy value 'DisableUserInstalls' is 0
    MSI (s) (DC:C8) [00:43:57:234]: File will have security applied from OpCode.
    MSI (s) (DC:C8) [00:43:58:343]: SOFTWARE RESTRICTION POLICY: Verifying package --> 'E:\Temp\install_healthframe_FamilyEdition_Release_2.1.4.msi' against software restriction policy
    MSI (s) (DC:C8) [00:43:58:343]: SOFTWARE RESTRICTION POLICY: E:\Temp\install_healthframe_FamilyEdition_Release_2.1.4.msi has a digital signature
    MSI (s) (DC:C8) [00:43:58:750]: SOFTWARE RESTRICTION POLICY: E:\Temp\install_healthframe_FamilyEdition_Release_2.1.4.msi is permitted to run at the 'unrestricted' authorization level.
    MSI (s) (DC:C8) [00:43:58:750]: End dialog not enabled
    MSI (s) (DC:C8) [00:43:58:750]: Original package ==> E:\Temp\install_healthframe_FamilyEdition_Release_2.1.4.msi
    MSI (s) (DC:C8) [00:43:58:750]: Package we're running from ==> C:\WINDOWS\Installer\1b21709.msi
    MSI (s) (DC:C8) [00:43:58:765]: APPCOMPAT: looking for appcompat database entry with ProductCode '{0C69483C-B0D2-4fb0-8C28-52EE0E783CEB}'.
    MSI (s) (DC:C8) [00:43:58:765]: APPCOMPAT: no matching ProductCode found in database.
    MSI (s) (DC:C8) [00:43:58:765]: MSCOREE not loaded loading copy from system32
    MSI (s) (DC:C8) [00:43:58:765]: Machine policy value 'TransformsSecure' is 0
    MSI (s) (DC:C8) [00:43:58:765]: User policy value 'TransformsAtSource' is 0
    MSI (s) (DC:C8) [00:43:58:765]: Machine policy value 'DisablePatch' is 0
    MSI (s) (DC:C8) [00:43:58:765]: Machine policy value 'AllowLockdownPatch' is 0
    MSI (s) (DC:C8) [00:43:58:765]: Machine policy value 'DisableLUAPatching' is 0
    MSI (s) (DC:C8) [00:43:58:765]: Machine policy value 'DisableFlyWeightPatching' is 0
    MSI (s) (DC:C8) [00:43:58:781]: APPCOMPAT: looking for appcompat database entry with ProductCode '{0C69483C-B0D2-4fb0-8C28-52EE0E783CEB}'.
    MSI (s) (DC:C8) [00:43:58:781]: APPCOMPAT: no matching ProductCode found in database.
    MSI (s) (DC:C8) [00:43:58:781]: Transforms are not secure.
    MSI (s) (DC:C8) [00:43:58:781]: PROPERTY CHANGE: Adding PackageCode property. Its value is '{6BA599B9-9F40-4D63-9EEE-5091D4431F40}'.
    MSI (s) (DC:C8) [00:43:58:781]: Product Code passed to Engine.Initialize:           ''
    MSI (s) (DC:C8) [00:43:58:781]: Product Code from property table before transforms: '{0C69483C-B0D2-4fb0-8C28-52EE0E783CEB}'
    MSI (s) (DC:C8) [00:43:58:781]: Product Code from property table after transforms:  '{0C69483C-B0D2-4fb0-8C28-52EE0E783CEB}'
    MSI (s) (DC:C8) [00:43:58:796]: Note: 1: 1708
    MSI (s) (DC:C8) [00:43:58:796]: Note: 1: 2729
    MSI (s) (DC:C8) [00:43:58:796]: Note: 1: 2729
    MSI (s) (DC:C8) [00:43:58:796]: Product: HealthFrame Family Edition 2.1 -- Installation failed.

    MSI (s) (DC:C8) [00:43:58:812]: MainEngineThread is returning 1605
    This action is only valid for products that are currently installed.
    MSI (c) (28:4C) [00:43:58:921]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
    MSI (c) (28:4C) [00:43:58:921]: MainEngineThread is returning 1605
    === Verbose logging stopped: 07/12/2006  00:43:58 ===

  •  12-06-2006, 10:30 AM 556 in reply to 554

    Re: About

    Hmm. That's interesting.

    First, I see you have multiple (virtual) hard drives (drive letters). Where is your default installation directory for program files? Is it C: or E:? (When you run the installer, this is the default choice for where HealthFrame will be installed).

    Have you always used that default location? Or did you sometimes install in another location?

    Also - do you really heave HealthFrame 2.1.4 installed? This logfile appears to indicate it didn't find HealthFrame 2.1.4 installed.

    I realized you did NOT need to download that MSI file I asked you to download.

    Instead - if you have HealthFrame 2.1.4 Family Edition instlaled - you should be able to un-install from the command-line using:

    •     msiexec /x {0C69483C-B0D2-4fb0-8C28-52EE0E783CEB} /lv myHFLog2.log

    If you don't mind - please make sure you have 2.1.4 HealthFrame Family Edition installed, and then run the above msiexec to uninstall it, and send me that logfile.

           Support Team.

View as RSS news feed in XML
Powered by Community Server, by Telligent Systems